aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-02-19 08:36:42 -0700
committerSean Whitton <spwhitton@spwhitton.name>2017-02-19 08:36:42 -0700
commit21d2353381164839ca16294e42057c3747396791 (patch)
tree00da6cb4ca156e8e5015d9fa77419a758a1c9c02
parentdc8f775b1f0a1f958bcb93d2044a3b3204657b55 (diff)
downloadgit-remote-gcrypt-21d2353381164839ca16294e42057c3747396791.tar.gz
replace quilt patch with call to `sed` in d/rules
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/0001-Debianise-README.patch24
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules9
4 files changed, 12 insertions, 25 deletions
diff --git a/debian/changelog b/debian/changelog
index 92e5825..31a02f1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,9 @@ git-remote-gcrypt (1.0.2) UNRELEASED; urgency=medium
* Switch to source format 3.0 (native).
- Override Lintian tag latest-debian-changelog-entry-changed-to-native.
- Drop override of Lintian tag debian-watch-file-is-missing.
+ * Add code to d/rules to remove installation instructions from the manpage.
+ This replaces the old quilt patch.
+
-- Sean Whitton <spwhitton@spwhitton.name> Sun, 19 Feb 2017 07:42:05 -0700
git-remote-gcrypt (1.0.1-1) unstable; urgency=low
diff --git a/debian/patches/0001-Debianise-README.patch b/debian/patches/0001-Debianise-README.patch
deleted file mode 100644
index e011664..0000000
--- a/debian/patches/0001-Debianise-README.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Sean Whitton <spwhitton@spwhitton.name>
-Date: Sun, 17 Jan 2016 22:47:52 -0700
-Subject: Debianise-README
-
-Remove reference to installation.
----
- README.rst | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/README.rst b/README.rst
-index 148abad..19a9d9d 100644
---- a/README.rst
-+++ b/README.rst
-@@ -27,9 +27,7 @@ PLEASE help us evaluate how well we meet this design goal!
- Quickstart
- ..........
-
--* Install ``git-remote-gcrypt`` by running the supplied ``install.sh`` script.
--
--* Create an encrypted remote by pushing to it::
-+Create an encrypted remote by pushing to it::
-
- git remote add cryptremote gcrypt::rsync://example.com:repo
- git push cryptremote master
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 93971b0..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-0001-Debianise-README.patch
diff --git a/debian/rules b/debian/rules
index 26ba625..42db5da 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,7 @@
#!/usr/bin/make -f
+
+manpage = debian/git-remote-gcrypt/usr/share/man/man1/git-remote-gcrypt.1
+
%:
dh $@
@@ -9,3 +12,9 @@ override_dh_auto_clean:
override_dh_auto_install:
prefix=/usr DESTDIR=debian/git-remote-gcrypt ./install.sh
+ # remove installation instructions from manpage (this is
+ # essentially an automatically-refreshing quilt patch)
+ gunzip ${manpage}.gz
+ sed -i ${manpage} -e \
+ '/^.SS Installation$$/,/^.SS/{ /^.SS Installation$$/d; /^.SS/!d }'
+ gzip -n ${manpage}