aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-07-04 17:35:11 +0900
committerSean Whitton <spwhitton@spwhitton.name>2016-07-04 17:35:11 +0900
commite2c5546b5d0290dbeba7018bd21ff2931ae8310a (patch)
treedc0bde4a75d4405137c78b590ae123f8387cb6b1
parent4e6dd11ffdbd55a72a3c2c24ea87b361bf94c29b (diff)
downloadgit-remote-gcrypt-e2c5546b5d0290dbeba7018bd21ff2931ae8310a.tar.gz
GCRYPT_GPG_ARGS env var -> gcrypt.gpg-args conf
-rw-r--r--README.rst7
-rw-r--r--debian/changelog2
-rwxr-xr-xgit-remote-gcrypt5
3 files changed, 7 insertions, 7 deletions
diff --git a/README.rst b/README.rst
index 148abad..6f0d9d7 100644
--- a/README.rst
+++ b/README.rst
@@ -77,6 +77,9 @@ The following ``git-config(1)`` variables are supported:
part of the participant list. You may use the per-remote version
to sign different remotes using different keys.
+``gcrypt.gpg-args``
+ The contents of this setting are passed as arguments to gpg.
+ E.g. ``--use-agent``.
Environment Variables
=====================
@@ -84,10 +87,6 @@ Environment Variables
*GCRYPT_FULL_REPACK*
This environment variable forces full repack when pushing.
-*GCRYPT_GPG_ARGS*
- The contents of this environment variable are passed as arguments
- to gpg. E.g. ``export GCRYPT_GPG_ARGS="--use-agent"``.
-
Examples
========
diff --git a/debian/changelog b/debian/changelog
index a01fb56..482a472 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,7 +4,7 @@ git-remote-gcrypt (1.0.0-1) UNRELEASED; urgency=medium
* Taking over as upstream maintainer.
Closes https://github.com/bluss/git-remote-gcrypt/issues/12
* Remove notice about repository format potentially changing.
- * Implement GCRYPT_GPG_ARGS environment variable (Closes: #771011).
+ * Implement gcrypt.gpg-args git config setting (Closes: #771011).
* Respect git config gpg.program if configured.
Thanks Christian Amsüss.
Closes https://github.com/joeyh/git-remote-gcrypt/pull/3
diff --git a/git-remote-gcrypt b/git-remote-gcrypt
index 54db709..bba6a22 100755
--- a/git-remote-gcrypt
+++ b/git-remote-gcrypt
@@ -372,9 +372,9 @@ rungpg()
# due to trying to print messages to it, even if a gpg agent is set
# up. --no-tty fixes this.
if [ "x$GPG_AGENT_INFO" != "x" ]; then
- ${GPG} --no-tty "${GCRYPT_GPG_ARGS:-}" "$@"
+ ${GPG} --no-tty "${Conf_gpg_args:-}" "$@"
else
- ${GPG} "${GCRYPT_GPG_ARGS:-}" "$@"
+ ${GPG} "${Conf_gpg_args:-}" "$@"
fi
}
@@ -409,6 +409,7 @@ read_config()
git config --get gcrypt.participants '.+' || :)
Conf_pubish_participants=$(git config --get --bool "remote.$NAME.gcrypt-publish-participants" '.+' ||
git config --get --bool gcrypt.publish-participants || :)
+ Conf_gpg_args=$(git config --get gcrypt.gpg-args '.+' || :)
# Figure out which keys we should encrypt to or accept signatures from
if isnull "$conf_part" || iseq "$conf_part" simple