aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog27
-rw-r--r--debian/control6
-rw-r--r--debian/copyright4
-rw-r--r--debian/patches/0001-Debianise-README.patch24
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules9
6 files changed, 41 insertions, 30 deletions
diff --git a/debian/changelog b/debian/changelog
index 81a4118..aa828c5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,30 @@
+git-remote-gcrypt (1.0.2-1) unstable; urgency=medium
+
+ Bug fixes:
+ * Correctly handle the case where gcrypt.gpg-args contains more than one
+ argument, separated by spaces.
+ Thanks Etienne Brodu for the patch.
+
+ Documentation:
+ * Drop section "Note to users of GnuPG version 2".
+ The issue was a regression in GnuPG 2.x, fixed in version 2.1.16.
+ * Add a note about performance when not using the rsync:// or local backends.
+ * Add section containing author and maintainer information.
+ * Add `apt-get` installation instructions, for the benefit of GitHub users.
+ * Other minor edits and formatting changes.
+
+ Debian packaging:
+ * Replace quilt patch with code in d/rules to remove installation
+ instructions from the manpage.
+ * Depend on gpg | gnupg1 and demote gnupg to a Recommends (Closes: #873498).
+ At least with passwordless PGP keys, git-remote-gcrypt works fine with
+ only the gpg package installed.
+ Thanks to Yuri D'Elia for the report.
+ * Bump copyright years.
+ * Bump standards version to 4.1.0 (no changes required).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Fri, 01 Sep 2017 14:34:35 -0700
+
git-remote-gcrypt (1.0.1-1) unstable; urgency=low
Upstream:
diff --git a/debian/control b/debian/control
index 79615b8..fcf6659 100644
--- a/debian/control
+++ b/debian/control
@@ -3,15 +3,15 @@ Section: vcs
Priority: optional
Build-Depends: debhelper (>= 10), python-docutils (>= 0.12+dfsg)
Maintainer: Sean Whitton <spwhitton@spwhitton.name>
-Standards-Version: 3.9.8
+Standards-Version: 4.1.0
Homepage: https://spwhitton.name/tech/code/git-remote-gcrypt/
Vcs-Git: https://git.spwhitton.name/git-remote-gcrypt
Vcs-Browser: https://git.spwhitton.name/git-remote-gcrypt
Package: git-remote-gcrypt
Architecture: all
-Depends: git, gnupg | gnupg2, ${misc:Depends}
-Recommends: rsync, curl
+Depends: git, gpg | gnupg1, ${misc:Depends}
+Recommends: rsync, curl, gnupg
Description: encrypted git repositories
This lets git store git repositories in encrypted form.
It supports storing repositories on rsync or sftp servers.
diff --git a/debian/copyright b/debian/copyright
index c5497b4..4ef440d 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -4,11 +4,11 @@ Source: https://git.spwhitton.name/git-remote-gcrypt
Files: *
Copyright: (C) 2013 engla
(C) 2013, 2014 Joey Hess <id@joeyh.name>
- (C) 2016 Sean Whitton and contributors
+ (C) 2016-2017 Sean Whitton and contributors
License: GPL-2+
Files: debian/*
-Copyright: (C) 2015-2016 Sean Whitton <spwhitton@spwhitton.name>
+Copyright: (C) 2015-2017 Sean Whitton <spwhitton@spwhitton.name>
(C) 2013, 2014 Joey Hess <id@joeyh.name>
License: GPL-2+
diff --git a/debian/patches/0001-Debianise-README.patch b/debian/patches/0001-Debianise-README.patch
deleted file mode 100644
index e011664..0000000
--- a/debian/patches/0001-Debianise-README.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Sean Whitton <spwhitton@spwhitton.name>
-Date: Sun, 17 Jan 2016 22:47:52 -0700
-Subject: Debianise-README
-
-Remove reference to installation.
----
- README.rst | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/README.rst b/README.rst
-index 148abad..19a9d9d 100644
---- a/README.rst
-+++ b/README.rst
-@@ -27,9 +27,7 @@ PLEASE help us evaluate how well we meet this design goal!
- Quickstart
- ..........
-
--* Install ``git-remote-gcrypt`` by running the supplied ``install.sh`` script.
--
--* Create an encrypted remote by pushing to it::
-+Create an encrypted remote by pushing to it::
-
- git remote add cryptremote gcrypt::rsync://example.com:repo
- git push cryptremote master
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 93971b0..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-0001-Debianise-README.patch
diff --git a/debian/rules b/debian/rules
index 26ba625..42db5da 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,7 @@
#!/usr/bin/make -f
+
+manpage = debian/git-remote-gcrypt/usr/share/man/man1/git-remote-gcrypt.1
+
%:
dh $@
@@ -9,3 +12,9 @@ override_dh_auto_clean:
override_dh_auto_install:
prefix=/usr DESTDIR=debian/git-remote-gcrypt ./install.sh
+ # remove installation instructions from manpage (this is
+ # essentially an automatically-refreshing quilt patch)
+ gunzip ${manpage}.gz
+ sed -i ${manpage} -e \
+ '/^.SS Installation$$/,/^.SS/{ /^.SS Installation$$/d; /^.SS/!d }'
+ gzip -n ${manpage}