summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2020-01-02 18:21:29 +0000
committerSean Whitton <spwhitton@spwhitton.name>2020-01-02 18:21:29 +0000
commit82194f4c43cd5055d964b60a7c4244376e20f5af (patch)
tree078e887e995a6b0ab5ef20a267d73889f3eaa0eb
parente2a73456824281a8c41813f168b435a95cf7d389 (diff)
downloadgit-repair-82194f4c43cd5055d964b60a7c4244376e20f5af.tar.gz
drop patches merged upstream
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/fix-build-with-quickcheck-2.8.2.patch34
-rw-r--r--debian/patches/patch-duplicate-arbitrary-instance-out-o.patch20
-rw-r--r--debian/patches/series3
-rw-r--r--debian/patches/split-out-module-to-work-around-badly-na.patch70
5 files changed, 4 insertions, 127 deletions
diff --git a/debian/changelog b/debian/changelog
index 4fe9c6e..325ccdf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,10 @@ git-repair (1.20200102-1) UNRELEASED; urgency=medium
- Tighten build-dep on optparse-applicative
- Add build-deps on split, filepath-bytestring, attoparsec
- Drop build-dep on missingh.
+ * Drop patches merged upstream:
+ - fix-build-with-quickcheck-2.8.2.patch
+ - patch-duplicate-arbitrary-instance-out-o.patch
+ - split-out-module-to-work-around-badly-na.patch.
* Stop adding upstream entries to debian/changelog.
* wrap-and-sort -abst
diff --git a/debian/patches/fix-build-with-quickcheck-2.8.2.patch b/debian/patches/fix-build-with-quickcheck-2.8.2.patch
deleted file mode 100644
index 3e3a0cd..0000000
--- a/debian/patches/fix-build-with-quickcheck-2.8.2.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Joey Hess <joeyh@joeyh.name>
-Date: Sun, 24 Jan 2016 14:15:00 -0400
-X-Dgit-Generated: 1.20151215-1.1 1ecd24cc076b15e085529d41e5a873e334f75167
-Subject: Fix build with QuickCheck 2.8.2
-
-It added some instances I had also implemented.
-
----
-
---- git-repair-1.20151215.orig/Utility/QuickCheck.hs
-+++ git-repair-1.20151215/Utility/QuickCheck.hs
-@@ -6,7 +6,7 @@
- -}
-
- {-# OPTIONS_GHC -fno-warn-orphans #-}
--{-# LANGUAGE TypeSynonymInstances #-}
-+{-# LANGUAGE TypeSynonymInstances, CPP #-}
-
- module Utility.QuickCheck
- ( module X
-@@ -21,11 +21,13 @@ import qualified Data.Set as S
- import Control.Applicative
- import Prelude
-
-+#if ! MIN_VERSION_QuickCheck(2,8,2)
- instance (Arbitrary k, Arbitrary v, Eq k, Ord k) => Arbitrary (M.Map k v) where
- arbitrary = M.fromList <$> arbitrary
-
- instance (Arbitrary v, Eq v, Ord v) => Arbitrary (S.Set v) where
- arbitrary = S.fromList <$> arbitrary
-+#endif
-
- {- Times before the epoch are excluded. -}
- instance Arbitrary POSIXTime where
diff --git a/debian/patches/patch-duplicate-arbitrary-instance-out-o.patch b/debian/patches/patch-duplicate-arbitrary-instance-out-o.patch
deleted file mode 100644
index 1334809..0000000
--- a/debian/patches/patch-duplicate-arbitrary-instance-out-o.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From: Sean Whitton <spwhitton@spwhitton.name>
-Date: Sun, 22 Jul 2018 14:30:36 +0800
-X-Dgit-Generated: 1.20151215-1.2 5e47ead106bebfd076d950934fbe11d9f1ef552c
-Subject: patch duplicate Arbitrary instance out of Utility/QuickCheck.hs
-
-
----
-
---- git-repair-1.20151215.orig/Utility/QuickCheck.hs
-+++ git-repair-1.20151215/Utility/QuickCheck.hs
-@@ -33,9 +33,6 @@ instance (Arbitrary v, Eq v, Ord v) => A
- instance Arbitrary POSIXTime where
- arbitrary = fromInteger <$> nonNegative arbitrarySizedIntegral
-
--instance Arbitrary EpochTime where
-- arbitrary = fromInteger <$> nonNegative arbitrarySizedIntegral
--
- {- Pids are never negative, or 0. -}
- instance Arbitrary ProcessID where
- arbitrary = arbitrarySizedBoundedIntegral `suchThat` (> 0)
diff --git a/debian/patches/series b/debian/patches/series
index ae13db9..621573e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1 @@
-fix-build-with-quickcheck-2.8.2.patch
-split-out-module-to-work-around-badly-na.patch
patch-common.hs-to-avoid-duplicate-impor.patch
-patch-duplicate-arbitrary-instance-out-o.patch
diff --git a/debian/patches/split-out-module-to-work-around-badly-na.patch b/debian/patches/split-out-module-to-work-around-badly-na.patch
deleted file mode 100644
index a8c3cbb..0000000
--- a/debian/patches/split-out-module-to-work-around-badly-na.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From: Joey Hess <joeyh@joeyh.name>
-Date: Sun, 22 May 2016 15:51:31 -0400
-X-Dgit-Generated: 1.20151215-1.1 e306cd8521a88c1cc39c926177a184adf9524886
-Subject: split out module to work around badly named symbol in directory-1.2.6.2
-
-Sadly my bug report about this is not going to get fixed it seems, so
-I have to drag around a whole added module file just to deal with it.
-
-https://github.com/haskell/directory/issues/52
-
----
-
---- git-repair-1.20151215.orig/Utility/Directory.hs
-+++ git-repair-1.20151215/Utility/Directory.hs
-@@ -8,10 +8,12 @@
- {-# LANGUAGE CPP #-}
- {-# OPTIONS_GHC -fno-warn-tabs #-}
-
--module Utility.Directory where
-+module Utility.Directory (
-+ module Utility.Directory,
-+ module Utility.SystemDirectory
-+) where
-
- import System.IO.Error
--import System.Directory
- import Control.Monad
- import System.FilePath
- import Control.Applicative
-@@ -28,6 +30,7 @@ import Utility.SafeCommand
- import Control.Monad.IfElse
- #endif
-
-+import Utility.SystemDirectory
- import Utility.PosixFiles
- import Utility.Tmp
- import Utility.Exception
-@@ -134,11 +137,13 @@ moveFile src dest = tryIO (rename src de
- _ <- tryIO $ removeFile tmp
- throwM e'
-
-+#ifndef mingw32_HOST_OS
- isdir f = do
- r <- tryIO $ getFileStatus f
- case r of
- (Left _) -> return False
- (Right s) -> return $ isDirectory s
-+#endif
-
- {- Removes a file, which may or may not exist, and does not have to
- - be a regular file.
---- /dev/null
-+++ git-repair-1.20151215/Utility/SystemDirectory.hs
-@@ -0,0 +1,16 @@
-+{- System.Directory without its conflicting isSymbolicLink
-+ -
-+ - Copyright 2016 Joey Hess <id@joeyh.name>
-+ -
-+ - License: BSD-2-clause
-+ -}
-+
-+-- Disable warnings because only some versions of System.Directory export
-+-- isSymbolicLink.
-+{-# OPTIONS_GHC -fno-warn-tabs -w #-}
-+
-+module Utility.SystemDirectory (
-+ module System.Directory
-+) where
-+
-+import System.Directory hiding (isSymbolicLink)