summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-11-18 13:39:52 -0400
committerJoey Hess <joey@kitenet.net>2013-11-18 13:39:52 -0400
commit91345e7d917c38e1bdcf9b2b01a5b7830a73eef7 (patch)
treeb1262f5bae1021054b1636512a434216fb8ff868
parent6cd59c40b116abbb5c1db1a8355caee84ef957d5 (diff)
downloadgit-repair-91345e7d917c38e1bdcf9b2b01a5b7830a73eef7.tar.gz
debianization
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control28
-rw-r--r--debian/copyright9
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules10
-rw-r--r--git-repair.cabal3
7 files changed, 57 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..2a2ffcb
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+git-repair (1.20131118) unstable; urgency=low
+
+ * First release
+
+ -- Joey Hess <joeyh@debian.org> Mon, 18 Nov 2013 13:38:12 -0400
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f4999d7
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,28 @@
+Source: git-repair
+Section: utils
+Priority: optional
+Build-Depends:
+ debhelper (>= 9),
+ ghc,
+ git,
+ libghc-missingh-dev,
+ libghc-hslogger-dev,
+ libghc-network-dev,
+ libghc-ifelse-dev,
+ libghc-extensible-exceptions-dev,
+ libghc-unix-compat-dev,
+ libghc-utf8-string-dev,
+ libghc-async-dev
+Maintainer: Joey Hess <joeyh@debian.org>
+Standards-Version: 3.9.4
+Vcs-Git: git://git-repair.branchable.com/
+Homepage: http://git-repair.branchable.com/
+
+Package: git-repair
+Architecture: any
+Section: utils
+Depends: ${misc:Depends}, ${shlibs:Depends}, git, rsync
+Description: repair various forms of damage to git repositorie
+ git-repair can repair various forms of damage to git repositories.
+ .
+ It is a complement to git fsck, which finds problems, but does not fix them.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..9d7912f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,9 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Source: native package
+
+Files: *
+Copyright: © 2013 Joey Hess <joey@kitenet.net>
+License: GPL-3+
+ The full text of version 3 of the GPL is distributed as doc/GPL in
+ this package's source, or in /usr/share/common-licenses/GPL-3 on
+ Debian systems.
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..4cad191
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+git-repair.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4d8fa21
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+# Avoid using cabal, as it writes to $HOME
+export CABAL=./Setup
+
+# Do use the changelog's version number, rather than making one up.
+export RELEASE_BUILD=1
+
+%:
+ dh $@
diff --git a/git-repair.cabal b/git-repair.cabal
index 6ab62fd..e649be0 100644
--- a/git-repair.cabal
+++ b/git-repair.cabal
@@ -13,6 +13,9 @@ Category: Utility
Synopsis: repairs a damanged git repisitory
Description:
git-repair can repair various forms of damage to git repositories.
+ .
+ It is a complement to git fsck, which finds problems, but does not fix
+ them.
Executable git-repair
Main-Is: git-repair.hs