summaryrefslogtreecommitdiff
path: root/Build/Configure.hs
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-11-18 13:53:38 -0400
committerJoey Hess <joey@kitenet.net>2013-11-18 13:53:38 -0400
commit50036caa0a39aaa2fef393a20f67d1f9ea35684c (patch)
treeb1f2fd95ea7e320dac7bb4406b785cd422487a33 /Build/Configure.hs
parent05355d4aab533d0c55666412b6c250e644bc7088 (diff)
downloadgit-repair-50036caa0a39aaa2fef393a20f67d1f9ea35684c.tar.gz
use debian/changelog for version
Diffstat (limited to 'Build/Configure.hs')
-rw-r--r--Build/Configure.hs6
1 files changed, 5 insertions, 1 deletions
diff --git a/Build/Configure.hs b/Build/Configure.hs
index 0c6245d..967738d 100644
--- a/Build/Configure.hs
+++ b/Build/Configure.hs
@@ -7,11 +7,13 @@ import Control.Applicative
import Control.Monad.IfElse
import Build.TestConfig
+import Build.Version
import Git.Version
tests :: [TestCase]
tests =
- [ TestCase "git" $ requireCmd "git" "git --version >/dev/null"
+ [ TestCase "version" getVersion
+ , TestCase "git" $ requireCmd "git" "git --version >/dev/null"
, TestCase "git version" getGitVersion
, TestCase "nice" $ testCmd "nice" "nice true >/dev/null"
]
@@ -25,3 +27,5 @@ run ts = do
args <- getArgs
config <- runTests ts
writeSysConfig config
+ whenM (isReleaseBuild) $
+ cabalSetup "github-repair.cabal"