summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog22
-rw-r--r--debian/compat1
-rw-r--r--debian/control29
-rw-r--r--debian/copyright9
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules10
6 files changed, 72 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..91d0bd2
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,22 @@
+git-repair (1.20131122) unstable; urgency=low
+
+ * Added test mode, which can be used to randomly corrupt test
+ repositories, in reproducible ways, which allows easy
+ corruption-driven-development.
+ * Improve repair code in the case where the index file is corrupt,
+ and this hides other problems.
+ * Write a dummy .git/HEAD if the file is missing or corrupt, as
+ git otherwise will not treat the repository as a git repo.
+ * Improve fsck code to find badly corrupted objects that crash git fsck
+ before it can complain about them.
+ * Fixed crashes on bad file encodings.
+ * Can now run 10000 tests (git-repair --test -n 10000 --force)
+ with 0 failures.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 22 Nov 2013 11:16:03 -0400
+
+git-repair (1.20131118) unstable; urgency=low
+
+ * First release
+
+ -- Joey Hess <joeyh@debian.org> Mon, 18 Nov 2013 13:38:12 -0400
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..bf14911
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,29 @@
+Source: git-repair
+Section: utils
+Priority: optional
+Build-Depends:
+ debhelper (>= 9),
+ ghc,
+ git,
+ libghc-missingh-dev,
+ libghc-hslogger-dev,
+ libghc-network-dev,
+ libghc-ifelse-dev,
+ libghc-extensible-exceptions-dev,
+ libghc-unix-compat-dev,
+ libghc-utf8-string-dev,
+ libghc-async-dev,
+ libghc-optparse-applicative-dev
+Maintainer: Joey Hess <joeyh@debian.org>
+Standards-Version: 3.9.4
+Vcs-Git: git://git-repair.branchable.com/
+Homepage: http://git-repair.branchable.com/
+
+Package: git-repair
+Architecture: any
+Section: utils
+Depends: ${misc:Depends}, ${shlibs:Depends}, git, rsync
+Description: repair various forms of damage to git repositorie
+ git-repair can repair various forms of damage to git repositories.
+ .
+ It is a complement to git fsck, which finds problems, but does not fix them.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..9d7912f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,9 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Source: native package
+
+Files: *
+Copyright: © 2013 Joey Hess <joey@kitenet.net>
+License: GPL-3+
+ The full text of version 3 of the GPL is distributed as doc/GPL in
+ this package's source, or in /usr/share/common-licenses/GPL-3 on
+ Debian systems.
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..4cad191
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+git-repair.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4d8fa21
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+# Avoid using cabal, as it writes to $HOME
+export CABAL=./Setup
+
+# Do use the changelog's version number, rather than making one up.
+export RELEASE_BUILD=1
+
+%:
+ dh $@