summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules14
1 files changed, 3 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 42f7d2b..918d4cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,12 @@
#!/usr/bin/make -f
-# these rules originally written by Joey Hess for hothasktags package
+export BUILDER=cabal
%:
dh $@
-override_dh_auto_configure:
- ghc --make Setup
- ./Setup configure
-
-override_dh_auto_build:
- ./Setup build
-
-override_dh_auto_clean:
- if [ -x Setup ]; then ./Setup clean; fi
- rm -f Setup Setup.o Setup.hi
+override_dh_auto_install:
+ $(MAKE) install-files
override_dh_strip:
# GHC cannot produce debugging symbols so the -dbgsym package