summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2019-11-20 22:19:15 -0700
committerSean Whitton <spwhitton@spwhitton.name>2019-11-20 22:19:15 -0700
commit33afb1e3af7ce05c8f2ce4af354c8908a14573f5 (patch)
tree3c0eae4836e7f20c054c193ac3e76da5e0462dfa /Makefile
parent914b13d9c578aab098f427aef88b7cbd5eb3f5a2 (diff)
parent693117551a0e21359ac6dbadba443516c56b04df (diff)
downloadmailscripts-33afb1e3af7ce05c8f2ce4af354c8908a14573f5.tar.gz
Merge tag 'debian/0.14-1' into buster-bpo
mailscripts release 0.14-1 for unstable (sid) [dgit] [dgit distro=debian no-split --quilt=linear] # gpg: Signature made Fri 15 Nov 2019 06:20:35 PM MST # gpg: using RSA key 9B917007AE030E36E4FC248B695B7AE4BF066240 # gpg: Good signature from "Sean Whitton <spwhitton@spwhitton.name>" [ultimate] # Primary key fingerprint: 8DC2 487E 51AB DD90 B5C4 753F 0F56 D055 3B6D 411B # Subkey fingerprint: 9B91 7007 AE03 0E36 E4FC 248B 695B 7AE4 BF06 6240
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 352f6f0..cd8f592 100644
--- a/Makefile
+++ b/Makefile
@@ -3,14 +3,21 @@ MANPAGES=mdmv.1 mbox2maildir.1 \
email-extract-openpgp-certs.1 \
email-print-mime-structure.1 \
notmuch-import-patch.1
+COMPLETIONS=completions/bash/email-print-mime-structure
-all: $(MANPAGES)
+all: $(MANPAGES) $(COMPLETIONS)
clean:
rm -f $(MANPAGES)
+ rm -rf completions
%.1: %.1.pod
pod2man --section=1 --date="Debian Project" --center="User Commands" \
--utf8 \
--name=$(subst .1,,$@) \
$^ $@
+
+completions/bash/%:
+ mkdir -p completions/bash
+ register-python-argcomplete3 $(notdir $@) >$@.tmp
+ mv $@.tmp $@