summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2019-12-04 07:38:11 -0700
committerSean Whitton <spwhitton@spwhitton.name>2019-12-04 07:38:11 -0700
commit7fc83b718cdf6e7abddb61810d2cc6bd3e584689 (patch)
tree6a0d4eb57b60de897a6f80a24f0782949a294daf /Makefile
parent7a5bdac3d0dc9d02ca75276bbb8fc1142247aaf1 (diff)
parentf3e1e5a552db990b2213ef850e056ecb7995558d (diff)
downloadmailscripts-7fc83b718cdf6e7abddb61810d2cc6bd3e584689.tar.gz
Merge tag 'debian/0.16-1' into buster-bpo
mailscripts release 0.16-1 for unstable (sid) [dgit] [dgit distro=debian no-split --quilt=linear] # gpg: Signature made Thu 28 Nov 2019 11:30:44 AM MST # gpg: using RSA key 9B917007AE030E36E4FC248B695B7AE4BF066240 # gpg: Good signature from "Sean Whitton <spwhitton@spwhitton.name>" [ultimate] # Primary key fingerprint: 8DC2 487E 51AB DD90 B5C4 753F 0F56 D055 3B6D 411B # Subkey fingerprint: 9B91 7007 AE03 0E36 E4FC 248B 695B 7AE4 BF06 6240
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index cd8f592..af30616 100644
--- a/Makefile
+++ b/Makefile
@@ -7,9 +7,13 @@ COMPLETIONS=completions/bash/email-print-mime-structure
all: $(MANPAGES) $(COMPLETIONS)
+check:
+ ./tests/email-print-mime-structure.sh
+ mypy --strict ./email-print-mime-structure
+
clean:
rm -f $(MANPAGES)
- rm -rf completions
+ rm -rf completions .mypy_cache
%.1: %.1.pod
pod2man --section=1 --date="Debian Project" --center="User Commands" \