summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2020-02-20 22:12:52 -0700
committerSean Whitton <spwhitton@spwhitton.name>2020-02-20 22:12:52 -0700
commitcc1f96c07dd0612e9ae44e41f889dd40315f0d75 (patch)
treebc960e456d1cba9a4070376d63443b1ec8b8f947 /Makefile
parent46cedb673ae6e63724d010d3fb6a47cc209502f5 (diff)
parentbbf1fc63fa1d88ea204a8cf272511ca85a828794 (diff)
downloadmailscripts-cc1f96c07dd0612e9ae44e41f889dd40315f0d75.tar.gz
Merge tag '0.18' into buster-bpo
release 0.18 # gpg: Signature made Sat 15 Feb 2020 03:11:16 PM MST # gpg: using RSA key 9B917007AE030E36E4FC248B695B7AE4BF066240 # gpg: issuer "spwhitton@spwhitton.name" # gpg: Good signature from "Sean Whitton <spwhitton@spwhitton.name>" [ultimate] # Primary key fingerprint: 8DC2 487E 51AB DD90 B5C4 753F 0F56 D055 3B6D 411B # Subkey fingerprint: 9B91 7007 AE03 0E36 E4FC 248B 695B 7AE4 BF06 6240
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index af30616..e2ae233 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,18 @@
MANPAGES=mdmv.1 mbox2maildir.1 \
notmuch-slurp-debbug.1 notmuch-extract-patch.1 maildir-import-patch.1 \
+ mbox-extract-patch.1 \
+ imap-dl.1 \
email-extract-openpgp-certs.1 \
email-print-mime-structure.1 \
notmuch-import-patch.1
-COMPLETIONS=completions/bash/email-print-mime-structure
+COMPLETIONS=completions/bash/email-print-mime-structure completions/bash/imap-dl
all: $(MANPAGES) $(COMPLETIONS)
check:
./tests/email-print-mime-structure.sh
mypy --strict ./email-print-mime-structure
+ mypy --strict ./imap-dl
clean:
rm -f $(MANPAGES)