summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index cd8f592..af30616 100644
--- a/Makefile
+++ b/Makefile
@@ -7,9 +7,13 @@ COMPLETIONS=completions/bash/email-print-mime-structure
all: $(MANPAGES) $(COMPLETIONS)
+check:
+ ./tests/email-print-mime-structure.sh
+ mypy --strict ./email-print-mime-structure
+
clean:
rm -f $(MANPAGES)
- rm -rf completions
+ rm -rf completions .mypy_cache
%.1: %.1.pod
pod2man --section=1 --date="Debian Project" --center="User Commands" \