aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..42f7d2b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+# these rules originally written by Joey Hess for hothasktags package
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ ghc --make Setup
+ ./Setup configure
+
+override_dh_auto_build:
+ ./Setup build
+
+override_dh_auto_clean:
+ if [ -x Setup ]; then ./Setup clean; fi
+ rm -f Setup Setup.o Setup.hi
+
+override_dh_strip:
+ # GHC cannot produce debugging symbols so the -dbgsym package
+ # ends up empty, so disable generating it
+ dh_strip --no-automatic-dbgsym