summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-04-16 09:05:42 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-04-16 09:05:42 -0700
commit836e8e201e35e8ea22b6fb0e0a16e9443a1437c1 (patch)
treef383008b3c4c4a468e8be9807c3ac21236b0cca6 /debian
parent5bc22a54bbbc28bb50cf1aa914a293671dada7f6 (diff)
downloadstylish-haskell-836e8e201e35e8ea22b6fb0e0a16e9443a1437c1.tar.gz
cdbs -> pure debhelper using hothasktags packaging
Diffstat (limited to 'debian')
-rw-r--r--debian/control37
-rw-r--r--debian/lintian-overrides1
-rwxr-xr-xdebian/rules19
3 files changed, 18 insertions, 39 deletions
diff --git a/debian/control b/debian/control
index c53510e..e6d2053 100644
--- a/debian/control
+++ b/debian/control
@@ -3,30 +3,17 @@ Maintainer: Sean Whitton <spwhitton@spwhitton.name>
Priority: extra
Section: haskell
Build-Depends: debhelper (>= 9),
- haskell-devscripts (>= 0.8),
- cdbs,
ghc,
- ghc-prof,
libghc-aeson-dev (>= 0.6),
libghc-aeson-dev (<< 0.12),
- libghc-aeson-prof (>= 0.6),
- libghc-aeson-prof (<< 0.12),
libghc-src-exts-dev (>= 1.17),
libghc-src-exts-dev (<< 1.18),
- libghc-src-exts-prof (>= 1.17),
- libghc-src-exts-prof (<< 1.18),
libghc-mtl-dev (>= 2.0),
libghc-mtl-dev (<< 2.3),
- libghc-mtl-prof (>= 2.0),
- libghc-mtl-prof (<< 2.3),
libghc-syb-dev (>= 0.3),
libghc-syb-dev (<< 0.7),
- libghc-syb-prof (>= 0.3),
- libghc-syb-prof (<< 0.7),
libghc-yaml-dev (>= 0.7),
libghc-yaml-dev (<< 0.9),
- libghc-yaml-prof (>= 0.7),
- libghc-yaml-prof (<< 0.9),
libghc-cmdargs-dev (>= 0.9),
libghc-cmdargs-dev (<< 0.11),
libghc-strict-dev (>= 0.3),
@@ -37,31 +24,15 @@ Build-Depends: debhelper (>= 9),
libghc-test-framework-dev (<< 0.9),
libghc-test-framework-hunit-dev (>= 0.2),
libghc-test-framework-hunit-dev (<< 0.4),
-Build-Depends-Indep: ghc-doc,
- libghc-aeson-doc,
- libghc-src-exts-doc,
- libghc-mtl-doc,
- libghc-syb-doc,
- libghc-yaml-doc,
Standards-Version: 3.9.8
Homepage: https://github.com/jaspervdj/stylish-haskell
-X-Description: Haskell code prettifier
- A Haskell code prettifier. For more information, see:
- .
- <https://github.com/jaspervdj/stylish-haskell/blob/master/README.markdown>
Vcs-Git: https://git.spwhitton.name/stylish-haskell
Vcs-Browser: https://git.spwhitton.name/?p=stylish-haskell.git;a=summary
Package: stylish-haskell
Architecture: any
-Section: misc
-Depends: ${haskell:Depends},
+Depends: ${shlibs:Depends},
${misc:Depends},
-Recommends: ${haskell:Recommends},
-Suggests: ${haskell:Suggests}, haskell-mode
-Conflicts: ${haskell:Conflicts},
-Provides: ${haskell:Provides},
-Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
- ${haskell:LongDescription}
- .
- ${haskell:Blurb}
+Suggests: haskell-mode
+Description: Haskell code prettifier
+ TODO
diff --git a/debian/lintian-overrides b/debian/lintian-overrides
new file mode 100644
index 0000000..25d3d4c
--- /dev/null
+++ b/debian/lintian-overrides
@@ -0,0 +1 @@
+binary-or-shlib-defines-rpath
diff --git a/debian/rules b/debian/rules
index 75f2efc..e9382c9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,17 @@
#!/usr/bin/make -f
-DEB_ENABLE_TESTS = yes
-DEB_CABAL_PACKAGE = stylish-haskell
-DEB_DEFAULT_COMPILER = ghc
+# these rules written by Joey Hess for hothasktags package
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/hlibrary.mk
+%:
+ dh $@
-build/stylish-haskell:: build-ghc-stamp
+override_dh_auto_configure:
+ ghc --make Setup
+ ./Setup configure
+
+override_dh_auto_build:
+ ./Setup build
+
+override_dh_auto_clean:
+ if [ -x Setup ]; then ./Setup clean; fi
+ rm -f Setup Setup.o Setup.hi