summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-04-16 14:18:16 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-04-16 14:18:16 -0700
commit0e4bacf3709d6d9991756eb63f8d213ae600ecc8 (patch)
treed9115f7eaa41e24911953c93ae3046683d613e2f /debian
parentd39dc3fda46248603d6554de57461b2e00eee8fd (diff)
downloadstylish-haskell-0e4bacf3709d6d9991756eb63f8d213ae600ecc8.tar.gz
run test suite
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7c33772..fbd6995 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,9 @@
override_dh_auto_configure:
ghc --make Setup
- ./Setup configure --datadir=/usr/share/stylish-haskell --datasubdir=""
+ ./Setup configure \
+ --datadir=/usr/share/stylish-haskell --datasubdir="" \
+ --enable-tests
override_dh_auto_build:
ronn <debian/stylish-haskell.1.ronn >debian/stylish-haskell.1
@@ -16,3 +18,6 @@ override_dh_auto_build:
override_dh_auto_clean:
if [ -x Setup ]; then ./Setup clean; fi
rm -f Setup Setup.o Setup.hi
+
+override_dh_auto_test:
+ ./Setup test