summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-06-24 15:23:41 +0900
committerSean Whitton <spwhitton@spwhitton.name>2016-06-24 15:23:41 +0900
commit2b62694a14fef93dea00ed5e72b29c4b5785b298 (patch)
tree48917ac9d3b890510ba8f12515cd5253b5cedc29 /debian
parent74e99a8f0f4416c74630346eabc7db0dd593c1c3 (diff)
downloadstylish-haskell-2b62694a14fef93dea00ed5e72b29c4b5785b298.tar.gz
generate manpage with asciidoctor
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules9
-rw-r--r--debian/stylish-haskell.1.adoc53
-rw-r--r--debian/stylish-haskell.1.ronn49
4 files changed, 61 insertions, 57 deletions
diff --git a/debian/changelog b/debian/changelog
index 32c5218..d685116 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+stylish-haskell (0.5.17.0-2) UNRELEASED; urgency=low
+
+ * General manpage with asciidoctor instead of ronn.
+ Second attempt at making it reproducible.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Fri, 24 Jun 2016 15:04:15 +0900
+
stylish-haskell (0.5.17.0-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/rules b/debian/rules
index 1a6cb2d..163b419 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,11 +2,6 @@
# these rules originally written by Joey Hess for hothasktags package
-# so that ronn builds the manual page reproducibly, get date from
-# changelog and print it in the format ronn expects
-DEB_CHANGELOG_STAMP_DATE = \
- $(shell date --date="$$(dpkg-parsechangelog -SDate)" +%Y-%m-%d)
-
%:
dh $@
@@ -17,9 +12,7 @@ override_dh_auto_configure:
--enable-tests
override_dh_auto_build:
- ronn --date=$(DEB_CHANGELOG_STAMP_DATE) \
- < debian/stylish-haskell.1.ronn \
- > debian/stylish-haskell.1
+ asciidoctor -d manpage -b manpage debian/stylish-haskell.1.adoc
./Setup build
override_dh_auto_clean:
diff --git a/debian/stylish-haskell.1.adoc b/debian/stylish-haskell.1.adoc
new file mode 100644
index 0000000..d441093
--- /dev/null
+++ b/debian/stylish-haskell.1.adoc
@@ -0,0 +1,53 @@
+= stylish-haskell(1)
+
+== NAME
+
+stylish-haskell - simple Haskell code prettifier
+
+== SYNOPSIS
+
+*stylish-haskell* [_-c_|_--config=FILE_] [_-v|--verbose_]
+[_-i_|_--inplace_] [_FILES_]...
+
+*stylish-haskell* _-d_|_--defaults_
+
+*stylish-haskell* _-V_|_--version_
+
+*stylish-haskell* _-?_|_--help_
+
+== DESCRIPTION
+
+*stylish-haskell* performs automatic formatting on the Haskell code in
+the files passed on the command line or piped via STDIN. It outputs to
+STDOUT unless *-i* is specified.
+
+=== OPTIONS
+
+*-c*, *--config=FILE*::
+ Override the default configuration file.
+
+*-v*, *--verbose*::
+ Turn on verbose output.
+
+*-i*, *--inplace*::
+ Prettify and overwrite the given files in place.
+
+*-d*, *--defaults*::
+ Dump default config and exit.
+
+*-V*, *--version*::
+ Output version information and exit.
+
+*-?*, *--help*::
+ Output help text and exit.
+
+== FILES
+
+*/usr/share/stylish-haskell/data/stylish-haskell.yaml*::
+ Default configuration file.
+
+== AUTHOR
+
+This manual page was originally written by Sean Whitton
+<\spwhitton@spwhitton.name> for the Debian GNU/Linux system (but may be
+used by others).
diff --git a/debian/stylish-haskell.1.ronn b/debian/stylish-haskell.1.ronn
deleted file mode 100644
index 385a7d2..0000000
--- a/debian/stylish-haskell.1.ronn
+++ /dev/null
@@ -1,49 +0,0 @@
-stylish-haskell(1) -- simple Haskell code prettifier
-====================================================
-
-## SYNOPSIS
-
-`stylish-haskell` [<-c>|<--config=FILE>] [<-v>|<--verbose>] [<-i>|<--inplace>] [<FILE>]...
-
-`stylish-haskell` <-d>|<--defaults>
-
-`stylish-haskell` <-V>|<--version>
-
-`stylish-haskell` <-?>|<--help>
-
-## DESCRIPTION
-
-`stylish-haskell` performs automatic formatting on the Haskell code in
-the files passed on the command line or piped via STDIN. It outputs
-to STDOUT unless `-i` is specified.
-
-### Options
-
- * `-c`, `--config`=[<file>]:
- Override the default configuration file.
-
- * `-v`, `--verbose`:
- Turn on verbose output.
-
- * `-i`, `--inplace`:
- Prettify and overwrite the given files in place.
-
- * `-d`, `--defaults`:
- Dump default config and exit.
-
- * `-V`, `--version`:
- Output version information and exit.
-
- * `-?`, `--help`:
- Output help text and exit.
-
-## FILES
-
- * `/usr/share/stylish-haskell/data/stylish-haskell.yaml`:
- Default configuration file.
-
-## AUTHOR
-
-This manual page was originally written by Sean Whitton
-<<spwhitton@spwhitton.name>> for the Debian GNU/Linux system (but may
-be used by others).