summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-06-21 14:43:51 +0900
committerSean Whitton <spwhitton@spwhitton.name>2016-06-21 14:43:51 +0900
commita4528552b404fd19a94e70a0c362b84e7f5d0291 (patch)
tree94210169ef91173362c31abe0197c45c2eb8aa4e /debian
parente323771765bfad159692e7be67a14782793d75c3 (diff)
downloadstylish-haskell-a4528552b404fd19a94e70a0c362b84e7f5d0291.tar.gz
build manpage reproducibly
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules9
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 23505e4..5df9b40 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ stylish-haskell (0.5.17.0-1) UNRELEASED; urgency=medium
- Dependency change: cmdargs -> optparse-applicative
* Drop 0002-move-CHANGELOG-entry-from-README.patch
Merged upstream.
+ * Pass changelog timestamp to ronn so manpage builds reproducibly.
-- Sean Whitton <spwhitton@spwhitton.name> Tue, 21 Jun 2016 14:17:51 +0900
diff --git a/debian/rules b/debian/rules
index 10e1c7d..1a6cb2d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,11 @@
# these rules originally written by Joey Hess for hothasktags package
+# so that ronn builds the manual page reproducibly, get date from
+# changelog and print it in the format ronn expects
+DEB_CHANGELOG_STAMP_DATE = \
+ $(shell date --date="$$(dpkg-parsechangelog -SDate)" +%Y-%m-%d)
+
%:
dh $@
@@ -12,7 +17,9 @@ override_dh_auto_configure:
--enable-tests
override_dh_auto_build:
- ronn <debian/stylish-haskell.1.ronn >debian/stylish-haskell.1
+ ronn --date=$(DEB_CHANGELOG_STAMP_DATE) \
+ < debian/stylish-haskell.1.ronn \
+ > debian/stylish-haskell.1
./Setup build
override_dh_auto_clean: