summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-04-16 14:02:04 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-04-16 14:02:04 -0700
commitd39dc3fda46248603d6554de57461b2e00eee8fd (patch)
tree8c808681411d74d8cb836dce6512a26f0e5273e5 /debian
parentcf1c2ed0642755e7edcfbab7845f0e4ee9377fe5 (diff)
downloadstylish-haskell-d39dc3fda46248603d6554de57461b2e00eee8fd.tar.gz
add a manpage
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules1
-rw-r--r--debian/stylish-haskell.1.ronn49
4 files changed, 52 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 7a8dc1e..e971224 100644
--- a/debian/control
+++ b/debian/control
@@ -24,6 +24,7 @@ Build-Depends: debhelper (>= 9),
libghc-test-framework-dev (<< 0.9),
libghc-test-framework-hunit-dev (>= 0.2),
libghc-test-framework-hunit-dev (<< 0.4),
+ ruby-ronn,
Standards-Version: 3.9.8
Homepage: https://github.com/jaspervdj/stylish-haskell
Vcs-Git: https://git.spwhitton.name/stylish-haskell
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..2af444d
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+debian/stylish-haskell.1
diff --git a/debian/rules b/debian/rules
index fae1d0d..7c33772 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,7 @@ override_dh_auto_configure:
./Setup configure --datadir=/usr/share/stylish-haskell --datasubdir=""
override_dh_auto_build:
+ ronn <debian/stylish-haskell.1.ronn >debian/stylish-haskell.1
./Setup build
override_dh_auto_clean:
diff --git a/debian/stylish-haskell.1.ronn b/debian/stylish-haskell.1.ronn
new file mode 100644
index 0000000..385a7d2
--- /dev/null
+++ b/debian/stylish-haskell.1.ronn
@@ -0,0 +1,49 @@
+stylish-haskell(1) -- simple Haskell code prettifier
+====================================================
+
+## SYNOPSIS
+
+`stylish-haskell` [<-c>|<--config=FILE>] [<-v>|<--verbose>] [<-i>|<--inplace>] [<FILE>]...
+
+`stylish-haskell` <-d>|<--defaults>
+
+`stylish-haskell` <-V>|<--version>
+
+`stylish-haskell` <-?>|<--help>
+
+## DESCRIPTION
+
+`stylish-haskell` performs automatic formatting on the Haskell code in
+the files passed on the command line or piped via STDIN. It outputs
+to STDOUT unless `-i` is specified.
+
+### Options
+
+ * `-c`, `--config`=[<file>]:
+ Override the default configuration file.
+
+ * `-v`, `--verbose`:
+ Turn on verbose output.
+
+ * `-i`, `--inplace`:
+ Prettify and overwrite the given files in place.
+
+ * `-d`, `--defaults`:
+ Dump default config and exit.
+
+ * `-V`, `--version`:
+ Output version information and exit.
+
+ * `-?`, `--help`:
+ Output help text and exit.
+
+## FILES
+
+ * `/usr/share/stylish-haskell/data/stylish-haskell.yaml`:
+ Default configuration file.
+
+## AUTHOR
+
+This manual page was originally written by Sean Whitton
+<<spwhitton@spwhitton.name>> for the Debian GNU/Linux system (but may
+be used by others).