summaryrefslogtreecommitdiffhomepage
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control60
1 files changed, 60 insertions, 0 deletions
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..aea985a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,60 @@
+Source: stylish-haskell
+Maintainer: Sean Whitton <spwhitton@spwhitton.name>
+Priority: optional
+Section: haskell
+Build-Depends: debhelper (>= 10),
+ ghc,
+ libghc-aeson-dev (>= 0.6),
+ libghc-aeson-dev (<< 1.5),
+ libghc-aeson-prof (>= 0.6),
+ libghc-aeson-prof (<< 1.5),
+ libghc-file-embed-dev (>= 0.0.10),
+ libghc-file-embed-dev (<< 0.1),
+ libghc-file-embed-prof (>= 0.0.10),
+ libghc-file-embed-prof (<< 0.1),
+ libghc-src-exts-dev (>= 1.18),
+ libghc-src-exts-dev (<< 1.22),
+ libghc-src-exts-prof (>= 1.18),
+ libghc-src-exts-prof (<< 1.22),
+ libghc-mtl-dev (>= 2.0),
+ libghc-mtl-dev (<< 2.3),
+ libghc-mtl-prof (>= 2.0),
+ libghc-mtl-prof (<< 2.3),
+ libghc-semigroups-dev (>= 0.18),
+ libghc-semigroups-dev (<< 0.20),
+ libghc-semigroups-prof (>= 0.18),
+ libghc-semigroups-prof (<< 0.20),
+ libghc-syb-dev (>= 0.3),
+ libghc-syb-dev (<< 0.8),
+ libghc-syb-prof (>= 0.3),
+ libghc-syb-prof (<< 0.8),
+ libghc-yaml-dev (>= 0.8.11),
+ libghc-yaml-dev (<< 0.12),
+ libghc-yaml-prof (>= 0.8.11),
+ libghc-yaml-prof (<< 0.12),
+ libghc-optparse-applicative-dev (>= 0.12),
+ libghc-optparse-applicative-dev (<< 0.15),
+ libghc-strict-dev (>= 0.3),
+ libghc-strict-dev (<< 0.4),
+ libghc-hunit-dev (>= 1.2),
+ libghc-hunit-dev (<< 1.7),
+ libghc-test-framework-dev (>= 0.4),
+ libghc-test-framework-dev (<< 0.9),
+ libghc-test-framework-hunit-dev (>= 0.2),
+ libghc-test-framework-hunit-dev (<< 0.4),
+ asciidoctor,
+Standards-Version: 4.1.1
+Homepage: https://github.com/jaspervdj/stylish-haskell
+Vcs-Git: https://git.spwhitton.name/stylish-haskell
+Vcs-Browser: https://git.spwhitton.name/stylish-haskell
+
+Package: stylish-haskell
+Architecture: any
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+Suggests: haskell-mode
+Description: Haskell code prettifier
+ stylish-haskell prettifies Haskell code. A design goal is not
+ getting in the user's way, so it restricts itself to formatting only
+ some parts of the Haskell code piped to it, such as import
+ statements.