summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7c33772..fbd6995 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,9 @@
override_dh_auto_configure:
ghc --make Setup
- ./Setup configure --datadir=/usr/share/stylish-haskell --datasubdir=""
+ ./Setup configure \
+ --datadir=/usr/share/stylish-haskell --datasubdir="" \
+ --enable-tests
override_dh_auto_build:
ronn <debian/stylish-haskell.1.ronn >debian/stylish-haskell.1
@@ -16,3 +18,6 @@ override_dh_auto_build:
override_dh_auto_clean:
if [ -x Setup ]; then ./Setup clean; fi
rm -f Setup Setup.o Setup.hi
+
+override_dh_auto_test:
+ ./Setup test