aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-10-25 18:56:46 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-10-25 18:56:46 -0700
commit07e4041e8dfb0b73b815424abb0b052a6cfe3937 (patch)
tree24a49b860f9fe0996c44b1ae4c5e94a517001a77
parent67081d680b12cf50c0929c24ad2f2d4789c6ea0f (diff)
downloadzxcvbn-c-07e4041e8dfb0b73b815424abb0b052a6cfe3937.tar.gz
refresh remaining patch
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/patch-README-for-Debian.patch36
2 files changed, 25 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index 6ee04fb..0a1d79e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ zxcvbn-c (2.0-1) UNRELEASED; urgency=medium
* Drop patches merged upstream:
- add-another-missing-file-to-clean-target.patch
- standardise-makefile-variables.patch
+ * Refresh patch-README-for-Debian.patch.
-- Sean Whitton <spwhitton@spwhitton.name> Tue, 25 Oct 2016 18:54:12 -0700
diff --git a/debian/patches/patch-README-for-Debian.patch b/debian/patches/patch-README-for-Debian.patch
index 260131d..5ca893f 100644
--- a/debian/patches/patch-README-for-Debian.patch
+++ b/debian/patches/patch-README-for-Debian.patch
@@ -10,34 +10,46 @@ Forwarded: not-needed
README.md | 19 +------------------
1 file changed, 1 insertion(+), 18 deletions(-)
-diff --git a/README.md b/README.md
-index e42b001..b5fa5bc 100644
--- a/README.md
+++ b/README.md
-@@ -9,28 +9,11 @@ The original coffee script version is available at
+@@ -11,42 +11,15 @@ The original coffee script version is av
An article on the reasons for zxcvbn is at
https://tech.dropox.com/2012/04/zxcvbn-realistic-password-strength-estimation
-##Building
-
--The makefile will build several test programs to test the code. It shows the steps needed to use the code in C and C++ programs, using the dictionary data read from file or included within the program executable.
--The makefile has only been tried on Linux using GCC version 4.8.4, but should be faily portable to other systems.
+-The makefile will build several test programs to test the code. It shows the steps needed
+-to use the code in C and C++ programs, using the dictionary data read from file or included
+-within the program executable.
+-The makefile has only been tried on Linux using GCC version 4.8.4, but should be faily
+-portable to other systems.
-
--When dictionary data is included in your program's executable, the files `zxcvbn.c` , `zxcvbn.h` , `dict-src.h` are used in your program.
+-When dictionary data is included in your program's executable, the files `zxcvbn.c` ,
+-`zxcvbn.h` , `dict-src.h` are used in your program.
-
--When dictionary data is read from file, the files `zxcvbn.c` , `zxcvbn.h` , `dict-crc.h` and `zxcvbn.dict` are used in your program, compiled with `#define USE_DICT_FILE`. The CRC of the dictionary data file is written to `dict-crc.h` so your executable can detect corruption of the data.
+-When dictionary data is read from file, the files `zxcvbn.c` , `zxcvbn.h` , `dict-crc.h`
+-and `zxcvbn.dict` are used in your program, compiled with `#define USE_DICT_FILE`. The CRC
+-of the dictionary data file is written to `dict-crc.h` so your executable can detect
+-corruption of the data.
-
-Rename `zxcvbn.c` to `zxcvbn.cpp` (or whatever your compiler uses) to compile as C++.
-
--The `dict*.h` and `zxcvbn.dict` files are generated by the dictgen program compiled from dict-generate.cpp (see makefile for details).
+-The `dict*.h` and `zxcvbn.dict` files are generated by the dictgen program compiled from
+-dict-generate.cpp (see makefile for details).
-
##Using
--Initially call `ZxcvbnInit()` with the pathname of the `zxcvbn.dict` file. This can be omitted when dictionary data is included in the executable.
--
- Call `ZxcvbnMatch()` with the password and optional user dictionary to get the entropy estimation and optional information on the password parts (which will need freeing with `ZxcvbnFreeInfo()` after use). Do this for each password to be tested, or as each character of it is entered into your program. The optional user dictionary can change between each call.
+-Initially call `ZxcvbnInit()` with the pathname of the `zxcvbn.dict` file. This can be
+-omitted when dictionary data is included in the executable.
+-
+ Call `ZxcvbnMatch()` with the password and optional user dictionary to get the entropy
+ estimation and optional information on the password parts (which will need freeing with
+ `ZxcvbnFreeInfo()` after use). Do this for each password to be tested, or as each character
+ of it is entered into your program. The optional user dictionary can change between each
+ call.
--Finally call `ZxcvbnUninit()` to free the dictionary data from read from file. This can be omitted when dictionary data is included in the executable.
+-Finally call `ZxcvbnUninit()` to free the dictionary data from read from file. This can be
+-omitted when dictionary data is included in the executable.
-
-Review the test program in `test.c` for an example.
+Review the test program in `examples/test.c` for an example.