aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a132819
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+# enable most hardening, but not PIE -- while we build some binary
+# executables in order to run the test suite, we only install
+# non-executable libraries
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
+
+-include /usr/share/dpkg/buildtools.mk
+export CXX_FOR_BUILD ?= g++
+
+%:
+ dh $@