aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2021-03-09 23:24:50 -0700
committerSean Whitton <spwhitton@spwhitton.name>2021-03-09 23:28:27 -0700
commitfe46aafabf79d4b468209c487c153a0637c153ee (patch)
tree4a8b0cd86281642bb80a0e053c48e0a5371db1d3 /debian/rules
parent7460b62ee07ae3a14530ab97022b8f2186e4a7b1 (diff)
downloadconsfigurator-fe46aafabf79d4b468209c487c153a0637c153ee.tar.gz
build and install consfigurator.el
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7e8a674..923e881 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,14 @@
#!/usr/bin/make -f
+ELPA_NAME=consfigurator
+export ELPA_NAME
+
%:
- dh $@ --with sphinxdoc
+ dh $@ --with sphinxdoc,elpa
override_dh_auto_build:
make -C doc html info
+ make -C emacs consfigurator.el
override_dh_auto_clean:
find src -name "*.fasl" -delete