aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2021-05-17 16:48:17 -0700
committerSean Whitton <spwhitton@spwhitton.name>2021-05-17 17:03:06 -0700
commit8dc928c2ca58e6116f6a35573bd6c97433f12400 (patch)
treec671a2c1f5651505fd92fa0f2d3dc285fe7faaa0 /debian
parente62ef34e5d8eb0bae9e5d89fb12756d8af9f4663 (diff)
downloadconsfigurator-8dc928c2ca58e6116f6a35573bd6c97433f12400.tar.gz
d/t/compile-and-tests.lisp: bind *PACKAGE* to CONSFIGURATOR/TESTS
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/tests/compile-and-tests.lisp10
2 files changed, 9 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 4bcf583..da3786e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,9 @@ consfigurator (0.6.0-1) UNRELEASED; urgency=medium
* New upstream release.
* Add dep and build-dep on cl-closer-mop.
+ * d/tests/compile-and-tests.lisp: Switch the *PACKAGE* to
+ CONSFIGURATOR/TESTS when running tests so that there is a value
+ for *CONSFIG*.
* d/rules: also clean *.fasl from tests/.
-- Sean Whitton <spwhitton@spwhitton.name> Tue, 13 Apr 2021 14:52:23 -0700
diff --git a/debian/tests/compile-and-tests.lisp b/debian/tests/compile-and-tests.lisp
index de3eb6c..57fe51d 100644
--- a/debian/tests/compile-and-tests.lisp
+++ b/debian/tests/compile-and-tests.lisp
@@ -7,9 +7,11 @@
(asdf:*user-cache* (uiop:getenv "AUTOPKGTEST_TMP")))
(asdf:load-system "consfigurator/tests"))
-;; we can't use ASDF:TEST-SYSTEM because its return value does not indicate
-;; whether any tests failed
-(unless (consfigurator/tests::do-tests)
- (uiop:quit 2))
+;; We can't use ASDF:TEST-SYSTEM because its return value does not indicate
+;; whether any tests failed. We have to switch the package back and forth as
+;; CL-USER has no *CONSFIG*.
+(let ((*package* (find-package :consfigurator/tests)))
+ (unless (consfigurator/tests::do-tests)
+ (uiop:quit 2)))
(fresh-line)