summaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2023-09-21 11:40:47 +0100
committerSean Whitton <spwhitton@spwhitton.name>2023-09-22 12:54:22 +0100
commit29ed239afdcf147d9328dbe9ebae0719fe870ad8 (patch)
treedab0c49f86a192e78093e71db74ea9a699cb2197 /debian/rules
parented4293ed38da3cc32fd2f333be22bda05d162c32 (diff)
downloaddebug-me-29ed239afdcf147d9328dbe9ebae0719fe870ad8.tar.gz
Disable link time optimisation on ppc64el
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 10 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 191cb01..b017b3c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,18 @@
#!/usr/bin/make -f
+DPKG_EXPORT_BUILDFLAGS := 1
+include /usr/share/dpkg/architecture.mk
+
# Debian's ghc cannot compile anything with -fPIC at present, so we
# have to disable PIE hardening to avoid build failures on archs like
# amd64. See discussion on debian-haskell@lists.debian.org
-export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
+DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
+
+# Building with LTO failed on ppc64el (LP: #2033639)
+ifeq ("$(DEB_BUILD_ARCH)", "ppc64el")
+ DEB_BUILD_MAINT_OPTIONS += optimize=-lto
+endif
+export DEB_BUILD_MAINT_OPTIONS
# cabal likes to write to $HOME, so use Setup.hs directly
export BUILDER = ./Setup