summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog36
-rw-r--r--debian/control4
-rw-r--r--debian/patches/debian-changes41
-rwxr-xr-xdebian/rules11
4 files changed, 64 insertions, 28 deletions
diff --git a/debian/changelog b/debian/changelog
index 67ad5df..2c08b91 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,39 @@
+debug-me (1.20221231-2) unstable; urgency=medium
+
+ * Disable link time optimisation on ppc64el (Closes: #1052313).
+ Thanks to Heinrich Schuchardt for the patch.
+ * Bump Aeson dependency bounds to allow 2.1 (Closes: #1054930).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Fri, 03 Nov 2023 10:21:15 +0000
+
+debug-me (1.20221231-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Tue, 04 Jul 2023 16:38:00 +0100
+
+debug-me (1.20220324-1) unstable; urgency=medium
+
+ * New upstream release.
+ * Update build-dep bounds for libghc-aeson-dev and libghc-websockets-dev.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sun, 22 May 2022 14:58:59 -0700
+
+debug-me (1.20200820-1) unstable; urgency=medium
+
+ * New upstream release (Closes: #968717).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sat, 22 Aug 2020 07:46:36 -0700
+
+debug-me (1.20190926-2) unstable; urgency=medium
+
+ * Fix build (Closes: #963862):
+ - Patch Val.hs for recent ghc: replace type constraint Monad -> MonadFail
+ - Patch Server.hs for recent Network.WebSockets: hide import of
+ Network.WebSockets.serverPort.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Tue, 14 Jul 2020 19:44:25 -0700
+
debug-me (1.20190926-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index f03d8d1..78d92cb 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Build-Depends: debhelper (>= 10),
dh-exec,
ghc (>= 8.4.3),
libghc-aeson-dev (>= 0.11),
- libghc-aeson-dev (<< 1.5),
+ libghc-aeson-dev (<< 2.2),
libghc-async-dev (>= 2.1),
libghc-cereal-dev (>= 0.5),
libghc-cryptonite-dev (>= 0.20),
@@ -33,7 +33,7 @@ Build-Depends: debhelper (>= 10),
libghc-wai-dev (>= 3.2),
libghc-wai-websockets-dev (>= 3.0),
libghc-warp-dev (>= 3.2),
- libghc-websockets-dev (>= 0.9),
+ libghc-websockets-dev (>= 0.12.6.0),
Standards-Version: 4.0.1
Homepage: https://debug-me.branchable.com/
Vcs-Git: https://git.spwhitton.name/debug-me
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index 47bb003..4f17f2a 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -15,8 +15,19 @@ upload of upstream version 1.2.3, you could use:
clone`.)
A single combined diff, containing all the changes, follows.
---- debug-me-1.20181208.orig/debug-me.init
-+++ debug-me-1.20181208/debug-me.init
+--- debug-me-1.20221231.orig/debug-me.cabal
++++ debug-me-1.20221231/debug-me.cabal
+@@ -64,7 +64,7 @@ Executable debug-me
+ , stm-chans (>= 3.0)
+ , posix-pty (>= 0.2.1)
+ , terminal-size (>= 0.3)
+- , aeson (>= 0.11 && < 2.1)
++ , aeson (>= 0.11 && < 2.2)
+ , sandi (>= 0.4)
+ , text (>= 1.2.2)
+ , optparse-applicative (>= 0.12)
+--- debug-me-1.20221231.orig/debug-me.init
++++ debug-me-1.20221231/debug-me.init
@@ -33,7 +33,7 @@ case "$1" in
start-stop-daemon --start --quiet --oknodo \
--background --no-close \
@@ -26,11 +37,11 @@ A single combined diff, containing all the changes, follows.
--exec "$DAEMON" -- $DAEMON_PARAMS \
> /var/log/debug-me.log
log_end_msg $?
---- debug-me-1.20181208.orig/debug-me.service
-+++ debug-me-1.20181208/debug-me.service
+--- debug-me-1.20221231.orig/debug-me.service
++++ debug-me-1.20221231/debug-me.service
@@ -8,8 +8,8 @@ EnvironmentFile=-/etc/default/debug-me
ExecStart=/usr/bin/debug-me $DAEMON_PARAMS
- InaccessiblePaths=/home /etc
+ InaccessiblePaths=/home
ReadWritePaths=/var/log/debug-me
-User=debug-me
-Group=debug-me
@@ -39,23 +50,3 @@ A single combined diff, containing all the changes, follows.
StandardInput=null
StandardOutput=journal
StandardError=journal
---- debug-me-1.20181208.orig/debug-me.cabal
-+++ debug-me-1.20181208/debug-me.cabal
-@@ -50,7 +50,7 @@ custom-setup
-
- Executable debug-me
- Main-Is: debug-me.hs
-- GHC-Options: -threaded -Wall -fno-warn-tabs -O2
-+ GHC-Options: -threaded -Wall -fno-warn-tabs -O2 -XNoMonadFailDesugaring
- Build-Depends:
- base (>= 4.9 && < 5.0)
- , network (>= 2.6)
-@@ -63,7 +63,7 @@ Executable debug-me
- , stm-chans (>= 3.0)
- , posix-pty (>= 0.2.1)
- , terminal-size (>= 0.3)
-- , aeson (>= 0.11 && < 1.4)
-+ , aeson (>= 0.11 && < 1.5)
- , sandi (>= 0.4)
- , text (>= 1.2.2)
- , optparse-applicative (>= 0.12)
diff --git a/debian/rules b/debian/rules
index 191cb01..b017b3c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,18 @@
#!/usr/bin/make -f
+DPKG_EXPORT_BUILDFLAGS := 1
+include /usr/share/dpkg/architecture.mk
+
# Debian's ghc cannot compile anything with -fPIC at present, so we
# have to disable PIE hardening to avoid build failures on archs like
# amd64. See discussion on debian-haskell@lists.debian.org
-export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
+DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
+
+# Building with LTO failed on ppc64el (LP: #2033639)
+ifeq ("$(DEB_BUILD_ARCH)", "ppc64el")
+ DEB_BUILD_MAINT_OPTIONS += optimize=-lto
+endif
+export DEB_BUILD_MAINT_OPTIONS
# cabal likes to write to $HOME, so use Setup.hs directly
export BUILDER = ./Setup