aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-02-19 08:36:42 -0700
committerSean Whitton <spwhitton@spwhitton.name>2017-02-19 08:36:42 -0700
commit21d2353381164839ca16294e42057c3747396791 (patch)
tree00da6cb4ca156e8e5015d9fa77419a758a1c9c02 /debian/rules
parentdc8f775b1f0a1f958bcb93d2044a3b3204657b55 (diff)
downloadgit-remote-gcrypt-21d2353381164839ca16294e42057c3747396791.tar.gz
replace quilt patch with call to `sed` in d/rules
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 26ba625..42db5da 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,7 @@
#!/usr/bin/make -f
+
+manpage = debian/git-remote-gcrypt/usr/share/man/man1/git-remote-gcrypt.1
+
%:
dh $@
@@ -9,3 +12,9 @@ override_dh_auto_clean:
override_dh_auto_install:
prefix=/usr DESTDIR=debian/git-remote-gcrypt ./install.sh
+ # remove installation instructions from manpage (this is
+ # essentially an automatically-refreshing quilt patch)
+ gunzip ${manpage}.gz
+ sed -i ${manpage} -e \
+ '/^.SS Installation$$/,/^.SS/{ /^.SS Installation$$/d; /^.SS/!d }'
+ gzip -n ${manpage}