summaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-10-22 10:04:57 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-10-22 10:04:57 -0700
commit7ec707f4dd3b4ce2363f82928ab5e8d2134017a6 (patch)
tree543cdd8dddd49b3415760617c12bdb2ead72b52b /debian/rules
parent63190dba1f72c79008bad7b9e0a3e29b59c96ee0 (diff)
downloadkeysafe-7ec707f4dd3b4ce2363f82928ab5e8d2134017a6.tar.gz
rules & dh_* files for package split
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules29
1 files changed, 25 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 918d4cc..8b1f148 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,35 @@
#!/usr/bin/make -f
-export BUILDER=cabal
+export BUILDER=./Setup
+# ^ see below
%:
dh $@
+override_dh_auto_test:
+ ./keysafe --test
+
+# upstream's install-files target is not sufficient for our split into
+# three binary packages, so disable it here and use dh_* tools
override_dh_auto_install:
- $(MAKE) install-files
+# GHC cannot produce debugging symbols
override_dh_strip:
- # GHC cannot produce debugging symbols so the -dbgsym package
- # ends up empty, so disable generating it
dh_strip --no-automatic-dbgsym
+
+# ensure service name is 'keysafe' not 'keysafe-server'. This is so
+# we are consistent with other distros despite our package split (see
+# INSTALL)
+override_dh_installinit:
+ dh_installinit --name=keysafe
+
+# use Setup.hs directly, not cabal, because cabal likes to write to
+# $HOME and can complain about needing a sandbox (this technique
+# originally from Joey Hess's hothasktags rules file)
+override_dh_auto_configure:
+ ghc --make Setup
+ ./Setup configure
+override_dh_auto_clean:
+ if [ -x Setup ]; then ./Setup clean; fi
+ rm -f Setup Setup.o Setup.hi keysafe
+ rm -rf dist .stack-work