summaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-10-01 14:28:52 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-10-01 14:28:52 -0700
commitb15db8321195abf8a45a6a053778a46b5afb5b2f (patch)
tree518ec259331df99841ed2fe3c296a6530ff91cbf /debian/rules
parent92afa32e228cf92a307320d409234745ffe598bc (diff)
downloadkeysafe-b15db8321195abf8a45a6a053778a46b5afb5b2f.tar.gz
rewrite d/rules in line with INSTALL
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 3 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 42f7d2b..918d4cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,12 @@
#!/usr/bin/make -f
-# these rules originally written by Joey Hess for hothasktags package
+export BUILDER=cabal
%:
dh $@
-override_dh_auto_configure:
- ghc --make Setup
- ./Setup configure
-
-override_dh_auto_build:
- ./Setup build
-
-override_dh_auto_clean:
- if [ -x Setup ]; then ./Setup clean; fi
- rm -f Setup Setup.o Setup.hi
+override_dh_auto_install:
+ $(MAKE) install-files
override_dh_strip:
# GHC cannot produce debugging symbols so the -dbgsym package