summaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index f0b77d3..efa37f3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,13 @@
#!/usr/bin/make -f
+# upstream's Makefile passes these on through ghc to gcc
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# cabal likes to write to $HOME, so use Setup.hs directly
export BUILDER = ./Setup
-# ^ cabal likes to write to $HOME
+
+# -j1 in the hope of making the build reproducible (see Makefile)
export BUILDEROPTIONS = -j1
-# ^ in the hope of making the build reproducible (see Makefile)
%:
dh $@