summaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..4614cc3
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,27 @@
+{ pkgs ? import ./haskell-pkgs.nix}:
+
+let
+ hsPkgs = import ./. { inherit pkgs; };
+in
+ hsPkgs.shellFor {
+ # Include only the *local* packages of your project.
+ # packages = ps: with ps; [
+ # ];
+
+ # Builds a Hoogle documentation index of all dependencies,
+ # and provides a "hoogle" command to search the index.
+ # withHoogle = true;
+
+ # You might want some extra tools in the shell (optional).
+ # Some common tools can be added with the `tools` argument
+ tools = { cabal = "3.2.0.0"; hlint = "2.2.11"; };
+ # See overlays/tools.nix for more details
+
+ # Some you may need to get some other way.
+ buildInputs = with pkgs.haskellPackages;
+ [ ghcid ];
+
+ # Prevents cabal from choosing alternate plans, so that
+ # *all* dependencies are provided by Nix.
+ exactDeps = true;
+ }