summaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-10-22 17:27:52 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-10-22 17:27:52 -0700
commitc5063c1f96d81c629096fae0c71e702a1bc6bca9 (patch)
tree653c79f69b26582c70190b07f79fd3f6f5b0dd95 /debian/rules
parent66c8c9f401c7d62cdea752f245bd486d66cae91f (diff)
downloadkeysafe-c5063c1f96d81c629096fae0c71e702a1bc6bca9.tar.gz
enable hardening & simplify rules
Thanks to Joey's changes in today's release
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 2 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index 9453d1d..c0fd936 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,8 @@
#!/usr/bin/make -f
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export BUILDER=./Setup
-# ^ see below
+# ^ cabal likes to write to $HOME
%:
dh $@
@@ -23,14 +24,3 @@ override_dh_strip:
# INSTALL)
override_dh_installinit:
dh_installinit --name=keysafe
-
-# use Setup.hs directly, not cabal, because cabal likes to write to
-# $HOME and can complain about needing a sandbox (this technique
-# originally from Joey Hess's hothasktags rules file)
-override_dh_auto_configure:
- ghc --make Setup
- ./Setup configure
-override_dh_auto_clean:
- if [ -x Setup ]; then ./Setup clean; fi
- rm -f Setup Setup.o Setup.hi keysafe
- rm -rf dist .stack-work