summaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 2 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index 9453d1d..c0fd936 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,8 @@
#!/usr/bin/make -f
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export BUILDER=./Setup
-# ^ see below
+# ^ cabal likes to write to $HOME
%:
dh $@
@@ -23,14 +24,3 @@ override_dh_strip:
# INSTALL)
override_dh_installinit:
dh_installinit --name=keysafe
-
-# use Setup.hs directly, not cabal, because cabal likes to write to
-# $HOME and can complain about needing a sandbox (this technique
-# originally from Joey Hess's hothasktags rules file)
-override_dh_auto_configure:
- ghc --make Setup
- ./Setup configure
-override_dh_auto_clean:
- if [ -x Setup ]; then ./Setup clean; fi
- rm -f Setup Setup.o Setup.hi keysafe
- rm -rf dist .stack-work