summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-10-23 12:31:19 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-10-23 12:31:19 -0700
commit73d678c4a3f47211587f7059a132fdf085650a47 (patch)
tree47e83ca37b1d246eb1f934da62199250d251fef3 /debian
parent2a284c2ce2909754e7dd391a8bfaac77c9b39e78 (diff)
downloadkeysafe-73d678c4a3f47211587f7059a132fdf085650a47.tar.gz
disable PIE hardening
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index efa37f3..963069e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,9 @@
#!/usr/bin/make -f
-# upstream's Makefile passes these on through ghc to gcc
-export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+# Debian's ghc cannot compile anything with -fPIC at present, so we
+# have to disable PIE hardening to avoid build failures on archs like
+# amd64. See discussion on debian-haskell@lists.debian.org
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
# cabal likes to write to $HOME, so use Setup.hs directly
export BUILDER = ./Setup