summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index efa37f3..963069e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,9 @@
#!/usr/bin/make -f
-# upstream's Makefile passes these on through ghc to gcc
-export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+# Debian's ghc cannot compile anything with -fPIC at present, so we
+# have to disable PIE hardening to avoid build failures on archs like
+# amd64. See discussion on debian-haskell@lists.debian.org
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
# cabal likes to write to $HOME, so use Setup.hs directly
export BUILDER = ./Setup