summaryrefslogtreecommitdiffhomepage
path: root/haskell-pkgs.nix
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2021-01-17 11:15:37 -0700
committerSean Whitton <spwhitton@spwhitton.name>2021-01-17 11:15:37 -0700
commit3130faccf7c9a9a7697e246884e2b60fd4b1f9de (patch)
treeab171724845fe928ef05692c27351be933228ec2 /haskell-pkgs.nix
parentfd8bfa2853825504c2dbc7678154ac8d56d47035 (diff)
parent84770e33bb6286c163c3b2b10fa98d264f6672b8 (diff)
downloadstylish-haskell-3130faccf7c9a9a7697e246884e2b60fd4b1f9de.tar.gz
Merge tag 'v0.12.2.0'
v0.12.2.0 - 0.12.2.0 (2020-10-08) * align: Add a new option for aligning only adjacent items (by 1Computer1) * align: Add support for aligning MultiWayIf syntax (by 1Computer1) * data: Fix some issues with record field padding * module_header: Add separate_lists option * imports: Respect separate_lists for (..) imports * data: Make sorting deriving list optional (by Maxim Koltsov)
Diffstat (limited to 'haskell-pkgs.nix')
-rw-r--r--haskell-pkgs.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/haskell-pkgs.nix b/haskell-pkgs.nix
new file mode 100644
index 0000000..729c2aa
--- /dev/null
+++ b/haskell-pkgs.nix
@@ -0,0 +1,18 @@
+let
+ # Fetch the latest haskell.nix and import its default.nix
+ haskellNix = import (builtins.fetchTarball{
+ url = "https://github.com/input-output-hk/haskell.nix/archive/f6663a8449f5e4a7393aa24601600c8f6e352c97.tar.gz";
+ }) {};
+
+# haskell.nix provides access to the nixpkgs pins which are used by our CI,
+# hence you will be more likely to get cache hits when using these.
+# But you can also just use your own, e.g. '<nixpkgs>'.
+ nixpkgsSrc = haskellNix.sources.nixpkgs-2003;
+
+# haskell.nix provides some arguments to be passed to nixpkgs, including some
+# patches and also the haskell.nix functionality itself as an overlay.
+ nixpkgsArgs = haskellNix.nixpkgsArgs;
+
+# import nixpkgs with overlays
+in
+ import nixpkgsSrc nixpkgsArgs