summaryrefslogtreecommitdiffhomepage
path: root/haskell-pkgs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'haskell-pkgs.nix')
-rw-r--r--haskell-pkgs.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/haskell-pkgs.nix b/haskell-pkgs.nix
new file mode 100644
index 0000000..729c2aa
--- /dev/null
+++ b/haskell-pkgs.nix
@@ -0,0 +1,18 @@
+let
+ # Fetch the latest haskell.nix and import its default.nix
+ haskellNix = import (builtins.fetchTarball{
+ url = "https://github.com/input-output-hk/haskell.nix/archive/f6663a8449f5e4a7393aa24601600c8f6e352c97.tar.gz";
+ }) {};
+
+# haskell.nix provides access to the nixpkgs pins which are used by our CI,
+# hence you will be more likely to get cache hits when using these.
+# But you can also just use your own, e.g. '<nixpkgs>'.
+ nixpkgsSrc = haskellNix.sources.nixpkgs-2003;
+
+# haskell.nix provides some arguments to be passed to nixpkgs, including some
+# patches and also the haskell.nix functionality itself as an overlay.
+ nixpkgsArgs = haskellNix.nixpkgsArgs;
+
+# import nixpkgs with overlays
+in
+ import nixpkgsSrc nixpkgsArgs